[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

I can't build from cvs sources on cygwin for some time now

From: Eric Lilja
Subject: I can't build from cvs sources on cygwin for some time now
Date: Sun, 12 Nov 2006 23:17:26 +0100
User-agent: Thunderbird (Windows/20061025)

Hello group!

Not sure when it broke, I have a build dated 11:th of september that works just fine. But when I tried to build a new version two weeks or so ago using the same procedure as before, it wouldn't build. Tried again now. Still won't build. Error:
In file included from emacsclient.c:286:
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/winsock2.h:103:2: warning: #warning "fd_set and associated macros have been defined in sys/types. This may cause runtime problems with W32 sockets" gcc -o oo-spd/i386/emacsclient.exe -mno-cygwin oo-spd/i386/emacsclient.o oo-spd/i386/getopt.o oo-spd/i386/getopt1.o oo-spd/i386/ntlib.o -lwsock32 -ladvapi32 oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0x11b): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0x1b9): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0x45b): undefined reference to `__imp___ctype_' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0x473): undefined reference to `__imp___ctype_' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0x4f0): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0x724): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0x7b4): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0x8b9): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0x923): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0xa2f): more undefined references to `___getreent' follow oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0xbc5): undefined reference to `_errno' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0xbd4): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0xcfc): undefined reference to `__imp___ctype_' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0xdd2): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0xe5e): undefined reference to `___getreent' oo-spd/i386/emacsclient.o:emacsclient.c:(.text+0xf29): undefined reference to `___getreent'
collect2: ld returned 1 exit status
mingw32-make[1]: *** [oo-spd/i386/emacsclient.exe] Error 1
mingw32-make[1]: Leaving directory `c:/cvsemacs/emacs/lib-src'
mingw32-make: *** [all-other-dirs-gmake] Error 2

My steps:
$ export CVS_RSH="ssh"
$ cvs -z3 -d:pserver:address@hidden:/sources/emacs co emacs
$ cd emacs/nt/
$ ./configure.bat --with-gcc --no-cygwin --no-debug
$ mingw32-make bootstrap-clean

Cygwin is fully updated (gcc version is 3.4.4-1), mingw32-make is version 3.81. I scanned this group and founds some posts seeming to indicate a problem with debug builds of emacs on cygwin using that version of gcc. I'm not building a debug build, but I built gcc-4.1.1 myself a few days ago just to try. Unfortunately, I couldn't build emacs using it (sorry, no error log). And even if I has succeeded doing that, I really would like to use cygwin's gcc so I can pass it -mno-cygwin because I don't want emacs to depend on cygwin1.dll. What should I do? I've been enjoying following the cvs version for more than two years now. There have been problems compiling before but they were usually fixed promptly. Now I don't even see any posts from people having the same problems as me... What prompted me to compile a new version from cvs was that I wanted to ask about a few problems I'm having and I wanted to test the latest sources first to see if they fixed the problems before I asked.

/ E

reply via email to

[Prev in Thread] Current Thread [Next in Thread]