[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Scim can't be activated when the arg --enable-font-backend is used.

From: Kenichi Handa
Subject: Re: Scim can't be activated when the arg --enable-font-backend is used.
Date: Thu, 07 Dec 2006 21:26:43 +0900

In article <address@hidden>, Hongyi Zhao <address@hidden> writes:

> Dear Kenichi,
> I've been bewildered by this problem, when I run emacs with:

> =============
> % emacs --enable-font-backend
> =============

> then, I can't activate the SCIM by C-SPC, when I run this:

> ============= 
> % M-x shell
> =============

> and run the command under shell environment of emacs like this:

> =========
> scim -d
> =========

> the emacs will say:

> =====================
> address@hidden:~$ scim -d
> Smart Common Input Method 1.4.4

> Launching a SCIM process with x11...
> Loading socket Config module ...
> Creating backend ...
> Loading x11 FrontEnd module ...
> Failed to launch SCIM.
> ====================

This typically happens when you have already running scim.

By the way, I've just commited another debugging code in

Please update your cvs working directory and make emacs as

% cd .../emacs

With this Emacs I get this kind of debugging information:

% LANG=zh_CN address@hidden emacs-unicode --enable-font-backend
XIC Fontset failed: -*-*-medium-r-normal--21-*-*-*-*-*
  missing: ISO8859-1
  missing: GB2312.1980-0
XIC Fontset created: -*-*-medium-r-normal--20-*-*-*-*-*

And I can activate scim by C-SPC.  What is your case?

Kenichi Handa

reply via email to

[Prev in Thread] Current Thread [Next in Thread]