[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Should libXt-devel be required to build Emacs?

From: Chong Yidong
Subject: Re: Should libXt-devel be required to build Emacs?
Date: Fri, 22 Dec 2006 14:25:58 -0500
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.92 (gnu/linux)

Richard Stallman <address@hidden> writes:

>     There's a problem with this: Autoconf 2.61 was only released in
>     November this year, and it requires a new version of M4 (1.4.8), which
>     in turn requires a new libc6.  Most existing GNU/Linux distributions
>     won't have these packages (at least in their "stable" branches).
> That's not so bad.  Most users don't need to rebuild the configure
> file, so they won't have a problem.
> However, we could ask the Autoconf developers to release a patched
> version 2.59.1 which fixes this bug and doesn't require a new M4.

Turns out it was a Debian packaging requirement rather than a real
requirement.  I have compiled autoconf 2.61 from source and checked in
a regenerated configure.

Let's hope there are no serious bugs in autoconf 2.61; it's a little
late in the release cycle to be making this kind of change.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]