[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacs -nw on Mac OS X

From: Piet van Oostrum
Subject: emacs -nw on Mac OS X
Date: Sun, 24 Dec 2006 22:31:15 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.92 (darwin)

The pretest (22.0.92) on Mac OS X when installed as a Mac OS X application
(/Application/Emacs.app) will not run properly in a terminal.

When the application is built in the mac subdirectory with the command:
./make-package --self-contained --build-in-place --app-symlink
emacs -nw or Applications/Emacs.app/Contents/MacOS/bin/emacs -nw complain:

Warning: arch-dependent data dir
(/usr/local/libexec/emacs/22.0.92/powerpc-apple-darwin8.8.0/) does not

I also tried to give the build command an additional --prefix option
./make-package --self-contained --build-in-place --app-symlink

Then the message becomes:
Warning: arch-dependent data dir
does not exist.

The real path of the architecture-dependent data dir is
/Applications/Emacs.app/Contents/Resources/libexec/, but this is only set
if emacs is started as /Applications/Emacs.app/Contents/MacOS/Emacs

Although this is a warning the resulting emacs fails, probably because
other paths also are incorrect.

I also tried to start emacs from a terminal with 
/Applications/Emacs.app/Contents/MacOS/Emacs -nw
but that complains about:
error: Mac native windows not in use or not initialized
Piet van Oostrum <address@hidden>
URL: http://www.cs.uu.nl/~piet [PGP 8DAE142BE17999C4]
Private email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]