[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: address@hidden: ffap not UTF-8 ready]

From: James Cloos
Subject: Re: address@hidden: ffap not UTF-8 ready]
Date: Tue, 26 Dec 2006 13:58:12 -0500
User-agent: Gnus/5.110006 (No Gnus v0.6) Emacs/23.0.0 (gnu/linux)

|> ffap is not UTF-8 ready, I put the cursor on ./???? or whatever and it
|> acts like the file Doesn't exist.

I tried it on several filenames (all of which exist on my filesystem).

On every file where the first character was ASCII and was not modified
by a combining character, ffap worked as expected.

But on every file where the second character was a combining character
(such as the file named C̶.utf8 -- that is a C followed by U+0336, which
is called COMBINING LONG STROKE OVERLAY) ffap failed to recognize the
string as being a filename.  It also failed when the string started
with a non-ASCII character, such as a kanji or a greek character.

Some testing shows that (ffap-string-at-point) skips strings such as
those described above.  I guess this is because of the default value
of ffap-string-at-point-mode-alist.  For finding files it looks for
strings of "--:$+<>@-Z_a-z~*?", dropping "<@" from the beginning and
dropping "@>;.,!:" from the end.  That first string needs to be
expanded to support non-ASCII characters which might be used for

James Cloos <address@hidden>         OpenPGP: 1024D/ED7DAEA6

reply via email to

[Prev in Thread] Current Thread [Next in Thread]