[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Another VC terminology change?

From: Stefan Monnier
Subject: Re: Another VC terminology change?
Date: Thu, 11 Oct 2007 16:08:27 -0400
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/23.0.50 (gnu/linux)

>> Not about "checkout" which sometimes means "update" and sometimes "get".
    sure    [sorry 'bout that]

>> But yes, "checkin" should be replaced by "commit".
>> This said, I don't know if we should change it only in the doc, or also in
>> the code, especially in the part of the code that interacts with the user
>> (i.e. commands) or the backends: I think it's important to make sure that
>> a single backend can work both with the new and the old VC.

> That compatibility is gone beyond retrieval.  It was already doomed when
> I moved the backends to taking fileset args,

It worked fine back then.  The backends just had to be careful to accept
both a list or a string and to treat a string as a list of 1 element.

> and I added another layer of impossible with the version -> revision
> terminology change.

We can (and maybe should) provide backward compatibility aliases to
handle that.

> So if we're going to do this change at all, it might as well be in docs and
> code both.  Maintaining consistency will save us problems later.

OK.  As said, we can (and maybe should) provide backward
compatibility aliases.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]