[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Proposed function: x-display-usable-bounds

From: Adrian Robert
Subject: Re: Proposed function: x-display-usable-bounds
Date: Tue, 4 Dec 2007 14:10:07 +0300

On Dec 3, 2007 5:56 PM, Stefan Monnier <address@hidden> wrote:
> > width height) for the usable screen area.  Since it seems relevant for
> > all platforms, it would seem appropriate to name this function with an
> > x- prefix, e.g., x-display-usable-bounds, and define it for all
> > platforms.  As a placeholder implementation, a list (0 0
> Actually, better *not* use an "x-" prefix for the main name.  I.e. name
> it "display-usable-bounds".  It's implementation may just check the
> display used by the selected frame and dispatch to
> x-display-usable-bounds,  w32-display-usable-bounds,
> mac-display-usable-bounds, ...

I followed the convention of x-display-pixel-width etc., which are a
class of lisp functions applicable on all windowing systems but called
directly as "x-..." from various places and very early, so that
aliasing didn't work (the Cocoa port tries to name its display
functions with a ns- prefix).

It seems the 'x-' prefix may sometimes mean "X-windows display
function" but is mostly used as "generic windowing system function".
Changing this might be good but it would make the most sense to do it
all at once after determining the best plan.

Note there is also an 'xw-' prefix used for some functions (e.g.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]