emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Carbon port emacs-unicode-2 build problem under MacOSX


From: YAMAMOTO Mitsuharu
Subject: Re: Carbon port emacs-unicode-2 build problem under MacOSX
Date: Tue, 12 Feb 2008 09:59:10 +0900
User-agent: Wanderlust/2.14.0 (Africa) SEMI/1.14.6 (Maruoka) FLIM/1.14.8 (Shij┼Ź) APEL/10.6 Emacs/23.0.50 (sparc-sun-solaris2.8) MULE/5.0 (SAKAKI)

>>>>> On Sat, 24 Nov 2007 18:18:27 +0900, YAMAMOTO Mitsuharu <address@hidden> 
>>>>> said:

>> Actually, as for the Carbon+AppKit port in 64-bit environment, it
>> compiles without any `deprecated' warnings and runs, though there
>> still remain a few major problems such as suspected ATSUI bug,
>> which I've already reported to Apple, and some unexec problem.

> The unexec problem seems to be solved.

The remaining 64-bit ATSUI bug seems to be fixed with Mac OS X 10.5.2
update.

> As I've installed the fix to the EMACS_22_BASE branch, you can try
> the 64-bit version of *X11* build on Leopard by specifying CC='cc
> -arch ppc64' or CC='cc -arch x86_64' when running configure.  Of
> course you need additional 64-bit versions of libraries to display
> various types of images.

> Could someone test if it works with x86_64?  I only have Leopard on
> a ppc64 machine.

Has anyone tested this?

                                     YAMAMOTO Mitsuharu
                                address@hidden




reply via email to

[Prev in Thread] Current Thread [Next in Thread]