[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 23.0.60 bootstrap fails for maemo

From: Thomas Baumann
Subject: Re: 23.0.60 bootstrap fails for maemo
Date: Sun, 17 Feb 2008 19:55:30 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

> Dan Nicolaescu <address@hidden> wrote:
>> Thomas Baumann <address@hidden> writes:
>>   > I'm trying to compile emacs23 for os2008 using the maemo-4.0 sdk but
>>   > somehow the bootstrap fails. I'm working with a fresh copy of the cvs
>>   > files checked out today. 
>>   > 
>>   > The problem looks very much like the emacs23/cygwin problem discussed
>>   > earlier, but I was not able to test all of the possible solutions
>>   > mentioned there.
>>   > 
>>   > Any help is highly appreciated.
>> Not sure if this helps, but first try to bootstrap on the host so that
>> you have all the .elc files, and then configure for the target again and
>> just run make. (If the problem you are facing is the byte compiler
>> encoding bug that's been discussed here, you might be able to get over
>> it this way)...
> I think I tried this before - configure with CHINOOK_X86 and compile
> (works ok). configure with CHINOOK_ARMEL... and a new error...
> if i delete and recompile pre-crt0.o for the target I get the same error
> as before

After days of testing and trying to debug the bootstrap I finally
compiled the byte-compile parts of bootstrap directly on the N810: and
it works :-) Strange and not a permanent solution, though. 

In summary, byte compilation segfaults during bootstrap using the maemo

1. the symptoms are the same mentioned in the "windows bootsrap failure
   thread". If someone could send me the things changed there or maybe
   have a look at what's necessary to implement the same changes for the
   arm target. 

2. charprop.el, uni-*.el (and maybe others) always have to be
   regenerated, thus raising the mentioned errors regardless if all the
   other lisp files are already compiled.

3. compilation is possible on the target itself: the build directory has
   to be mounted with nfs and make has to be installed on the
   device. Compile emacs until the first error occurs, continue on the
   target and finally make install and build the package on the host.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]