[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

The new newsticker doesn't show my feeds

From: Tassilo Horn
Subject: The new newsticker doesn't show my feeds
Date: Tue, 17 Jun 2008 18:15:10 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

Hi all,

since the latest changes to newsticker I cannot read my feeds anymore.
My config (which worked fine with the old newsticker) is as follows:

--8<---------------cut here---------------start------------->8---
(autoload 'w3m-region "w3m"
  "Render region in current buffer and replace with result." t)

(setq newsticker-url-list
      '(;; Emacs
        ("Planet Emacsen" "http://planet.emacsen.org/atom.xml";)
        ;; Computer, Software & Linux
        ("Pro-Linux News" "http://www.pro-linux.de/backend/pro-linux.rdf";)
        ("heise online News" "http://www.heise.de/newsticker/heise-atom.xml";)
        ("NewsForge" "http://www.newsforge.com/index.rss";)
        ("Slashdot" "http://slashdot.org/index.rss";)
        ("The Daily WTF" "http://thedailywtf.com/rss.aspx";)
        ;; FSF
        ("BadVista Blog" "http://badvista.fsf.org/blog/RSS";)
        ("BadVista - VistaWatch" 
        ("DefectiveByDesign.org - The Campaign to Eliminate DRM"
        ("Fellowship News" "http://www.fsfe.org/en/rss/feed/news_rss20";)
        ;; Programming
        ("Common-Lisp.net" "http://common-lisp.net/rss.xml";)
        ("Planet Lisp" "http://planet.lisp.org/rss20.xml";)
        ;; Nachrichten
        ("tagesschau.de - Die Nachrichten der ARD" 
        ;; Uni
        ("Inforakel" "http://www.inforakel.de/RSSFeeds/CurrentNewsEvents";)
        ("GHRKO News" "http://www.uni-koblenz.de/GHRKO/RSSFeed";)
        ("Neuigkeiten des FB4" "http://www.uni-koblenz.de/FB4/News/RSSFeed";)
        ;; Mail
        ("FastMail.FM status weblog" "http://status.fastmail.fm/?feed=rss2";)
        ;; Blog
        ("Tassilo's Blog" "http://tsdh.wordpress.com/feed/";)
        ("Comments for Tassilo's Blog" 
      newsticker-html-renderer 'w3m-region
      newsticker-cache-filename "~/.emacs.d/newsticker-cache"
      newsticker-automatically-mark-items-as-old nil)
--8<---------------cut here---------------end--------------->8---

Now, when I do `M-x newsticker-show-news' a new frame pops up [1]
showing three windows containing the buffers "*Newsticker Tree*",
"*Newsticker List*" and "*Newsticker Item*".  In the echo area I can see
that my feeds are fetched.

The first window (buffer "*Newsticker Tree*") contains the propertized

[X] Feeds
[X] Virtual Feeds

but no feeds.  Hitting RET on these [X] makes them [+], but still no
feeds are shown.  The "*Newsticker List*" buffer has a header line
containing Date and Title, but no contents.  The "*Newsticker Item*"
buffer is empty.

What am I missing?

[1] Can this be deactivated?  I'd like to use the current frame.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]