[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: shell-mode: point left in the wrong place after output

From: T. V. Raman
Subject: Re: shell-mode: point left in the wrong place after output
Date: Fri, 20 Jun 2008 06:12:30 -0700

So the behavior I'm seeing in the shell-mode buffer is identical
to what you report. 
I've not chased down the cause yet.

>>>>> "Stephen" == Stephen Berman <address@hidden> writes:
    Stephen> On Thu, 19 Jun 2008 22:06:53 -0400 Stefan Monnier
    Stephen> <address@hidden> wrote:
    >>> This is using the latest CVS snapshot.
    >> I don't know what you mean by "CVS snapshot", but I'll
    >> assume you mean that you recently updated your CVS check
    >> out.
    >>> It looks like point gets left at the front of the
    >>> inserted outputfrom frm a shell command, rther than at
    >>> the end.
    >>> Test:
    >>> See output below: echo foo foo
    >> I tried:
    >> emacs -Q M-x shell-mode RET echo foo RET
    >> and it worked just fine, with point ending right after the
    >> prompt.  Can you provide a more precise recipe?
    Stephen> It happens with `C-u M-! echo foo'.  But IIUC this
    Stephen> is supposed to happen: in shell-command the mark is
    Stephen> set before the output and after the output is
    Stephen> inserted point returns to the mark.  I suppose this
    Stephen> is to facilitate editing the shell command output?
    Stephen> Steve Berman

Best Regards,

Email:  address@hidden
WWW:    http://emacspeak.sf.net/raman/
AIM:    emacspeak       GTalk: address@hidden
PGP:    http://emacspeak.sf.net/raman/raman-almaden.asc
Google: tv+raman 
IRC:    irc://irc.freenode.net/#emacs

reply via email to

[Prev in Thread] Current Thread [Next in Thread]