[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cygwin emacs - does it work?

From: Lennart Borgman (gmail)
Subject: Re: Cygwin emacs - does it work?
Date: Tue, 05 Aug 2008 17:08:20 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20071031 Thunderbird/ Mnenhy/

Angelo Graziosi wrote:
Lennart Borgman wrote:

I just out of curiosity installed Cygwin Emacs. Now I am more curious about why this version of Emacs is there.

For me nearly nothing works in this Emacs. For example typing C-c results in C-g. Trying to examine a variable results in the error message "Cannot open load file: pp". Trying to send a bug report I am told that Emacs can not load emacsbug. Etc.

The about page says

  GNU Emacs 22.1.1 (i686-pc-cygwin)
   of 2007-07-19 on HERRING

Is there anyone to contact about this?

Which package have you installed?

The first I installed was

    emacs: The extensible, customizable ...

That is the one which has the problems I reported above.

Then later I installed the X version

    emacs-X11: ...

This works (as far as I tested, I do not know Emacs 21 very well).

In Cygwin the current version of Emacs is 21.2-13, instead 22.1 is in the test section, i.e. it is an experimental package.

It is more than an year that it is there without being promoted to current because people reported it crashes (see [1] and its replays).

The fact is that since version 22 Emacs is unstable when built with gcc-3.4.4 (the current version on Cygwin) and its maintainer on Cygwin is waiting for 4... series, with which it is enough stable. Perhaps this explain why 22.2 isn't neither in test version.

Thanks, I see, but then perhaps the package I installed should be removed, because it does not work either (at least not for me).

Following [1], you can find other useful information.


[1] http://cygwin.com/ml/cygwin/2007-07/msg00609.html

reply via email to

[Prev in Thread] Current Thread [Next in Thread]