[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Display problems with non-ascii characters

From: Sascha Wilde
Subject: Re: Display problems with non-ascii characters
Date: Fri, 10 Oct 2008 09:45:44 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

Kenichi Handa <address@hidden> wrote:
> In article <address@hidden>, Sascha Wilde <address@hidden> writes:
>> 1. emacs -Q
>> 2. C-h H    ; to bring up the Hello file
>>             ; watch out for the German line: "Guten Tag, Grüß Gott"
>> 3. M-x set-default-font RET terminus RET
>>             ; now the bug shows: the umlauts are gone the line looks
>>             ; like: "Guten Tag, Gr   Gott"
>> C-u C-x =  on the vanished `ß' shows:
> I still can't reproduce it.

I have some new findings on that, details below...

> By the way, in step 3, do you really see 3 spaces between
> "Gr" and "Gott"?  Aren't there any other vanishing
> characters?

Yes, 3: one for the missing ü one for the missing ß and the one which
belongs there (between the two words).

But please note that the two spaces which are really the vanished
Umlauts are more like "holes" in the X display: When I move the cursor
on them, the cursor vanishes, too -- and when I jump in the buffer, so
that the vanished chars would be displayed in a place where an other
character was displayed before, this character stays, no space, but the
wrong character, with fontification, color and all, just as if the
missing characters left a hole, do redraw takes place where they would
be, the space isn't even cleared...

That said, here are my latest findings:

Thirst thing I did this morning was to try my one receipt, with no
success(sic!) -- thirst thought: a change in the nightly build fixed or
at least changed it.

So I started my Emacs without `-Q' and started to work, running gnus I
immediately noticed a missing Umlaut in one of the mails Subjects...

So I re tried my receipt with a fresh `emacs -Q' (running on a different
machine, but on the same X11 display) and what shall I say?  It "worked"
again, the bug was back...

So It seems the problem might really be a strange X11 bug, which is
triggered by the new Emacs display code?

Any Ideas how to debug this?
(FWIW this is xorg 7.1.0-19 from Debian Etch)

Sascha Wilde : VI is to EMACS as masturbation is to making love:
             : effective and always available but probably not your
             : first choice...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]