emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ruby-mode : ruby-mode-set-encoding


From: Nobuyoshi Nakada
Subject: Re: ruby-mode : ruby-mode-set-encoding
Date: Wed, 04 Mar 2009 09:23:23 +0900
User-agent: Wanderlust/2.15.5 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.7 Emacs/22.3 (i386-apple-darwin9.6.0) MULE/5.0 (SAKAKI)

Hi,

At Tue, 03 Mar 2009 11:30:51 -0500,
Stefan Monnier wrote:
> I don't know if it's too intrusive, but it seems unrelated to Ruby.
> Nobuyoshi Nakada, looking at the history of ruby-mode.el at
> http://svn.ruby-lang.org/repos/ruby/trunk/misc, it appears the change is
> due to you, could you explain what this is intended to do?
> If it's not specific to Ruby, then maybe it should be moved elsewhere.

It's mandatory for Ruby 1.9 or later.  Ruby 1.9 needs that
"magic comment" to know in what encoding a script is written.
Otherwise, the script is assumed as written with ASCII 7bit
characters only, and non-ASCII character causes an exception if
exists.

Could you elaborate the problem?

-- 
Nobu Nakada




reply via email to

[Prev in Thread] Current Thread [Next in Thread]