[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Font Problem with - wrong font used

From: Taylor Venable
Subject: Re: Font Problem with - wrong font used
Date: Mon, 13 Apr 2009 23:14:19 -0400
User-agent: Mutt/1.5.18 (2008-05-17)

On Tue, Apr 14, 2009 at 10:07:04AM +0900, Kenichi Handa wrote:
> In article <address@hidden>, Taylor Venable <address@hidden> writes:
> > It looks a lot better now.  Without the ja font, from a preliminary
> > look everything seems to be good.  (See attached screenshot named
> > emacs-no-ja-font.png)  However, with the ja font in the font path
> > things are still a little off; bold faces are the wrong width (80
> > rather than the requested 70) and some other faces (like tooltip and
> > inactive mode line) use the "semicondensed" variant rather than the
> > "normal" variant.  The default face is now correct though.  See
> > attached screenshot named emacs-with-ja-font.png in the highlighted
> > areas for the things that are still not quite right.
> Ummm, weird.  Please define this function:
> (defun font-file-at ()
>   (interactive)
>   (message "%s" (aref (query-font (font-at (point))) 1)))
> and run it while putting cursor on "abc..." of `default',
> `mode-line-inactive', and `tooltip' lines in *Faces* buffer
> that is shown by M-x list-faces-display RET.

First, when the Japanese font is present:

default: /usr/X11R6/lib/X11/fonts/misc/7x13-ISO8859-1.pcf.gz
mode-line-inactive: [the same]
tooltip: [the same]

Strangely enough, the font shown as the example for 'default' is not
the font used in the buffer display; again it appears to be the semi-
condensed variant, whereas the font used in the buffer display appears
to be the correct normal variant.  If I do M-x customize-face default
I notice that the value has been set outside customize, and telling it
to set for the current session redisplays the buffer using the semi-
condensed face.

When I run this function on 'bold' I get nil.  Finding a face that
looks like what I want and see in the buffer display, the function
reports the value as /usr/X11R6/lib/X11/fonts/misc/7x13.pcf.gz - but
the font for the 'bold-italic' face which also looks correct (there is
no italic slant variant for the -misc-fixed font I'm using) is


Without the Japanese font in the font path, I get these:

default: /usr/X11R6/lib/X11/fonts/misc/7x13.pcf.gz
bold: /usr/X11R6/lib/X11/fonts/misc/8x13B-ISO8859-1.pcf.gz

It seems as if these are the fonts that I want for normal and bold,
respectively.  It seems as if the default and bold faces are being
chosen incorrectly while the Japanese font is present.

Taylor Christopher Venable

reply via email to

[Prev in Thread] Current Thread [Next in Thread]