[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug in highlight-lines-matching-regexp?

From: Tassilo Horn
Subject: Re: Bug in highlight-lines-matching-regexp?
Date: Mon, 20 Apr 2009 17:44:19 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.92 (gnu/linux)

Deniz Dogan <address@hidden> writes:

Hi Deniz,

>>>> I recently found some strange behavior in the highlighting
>>>> functionality provided by highlight-lines-matching-regexp. I'm not
>>>> sure whether this is a bug or not, which is why I'm asking.
>>>> Reproduction:
>>>> 1. Open a text file with any relevant contents.
>>>> 2. M-x highlight-lines-matching-regexp and highlight something in the file.
>>>> 3. M-x revert-buffer RET yes RET
>>>> 4. Now the highlighting is gone, which I can accept, however...
>>>> 5. M-x highlight-lines-matching-regexp RET RET
>>>> 6. Nothing is highlighted this second time!
>>>> Is this a bug or expected behavior?
>>> I've just tried it, and it works for me as it should when reusing
>>> the previous regexp (which is the default) in step 5.
>>> Did you try with "emacs -Q" to be sure that no local customization
>>> causes the breakage?
>> Yes, I tried this with emacs -Q and I still experience the same
>> behaviour. FWIW, here's the output from view-lossage:
> And oh, yeah, I'm using Emacs

Oh, I can reproduce this problem using "emacs -Q" and

    M-x view-hello-file RET

followed by your recipe.

It's not possible to highlight lines matching the previous regexp
altogether.  No matter if I use the default (previous) value at the
highlight-lines-matching-regexp prompt or if I enter the regexp anew,
nothing will be highlighted.  Different regexps work, though.

But if I try the same and use my ~/.emacs as file, it works as expected.
Maybe it's related to some encoding issues?  The HELLO file uses
iso-2022-7bit-unix whereas my ~/.emacs uses utf-8-unix.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]