[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Rename `mini-' options

From: Drew Adams
Subject: Rename `mini-' options
Date: Fri, 15 May 2009 13:59:17 -0700

Names such as `resize-mini-windows' and `max-mini-window-height' are
unfortunate. They prevent you from easily finding them by looking for names that
include `minibuffer' or even `minibuf'.
Since when did `mini' start being used in option etc. names to stand for the
minibuffer? The only variable names with `mini-' are these two plus
`kmacro-step-edit-mini-window-height'. Obviously, given the last of these, the
name length is not of supreme importance. And there are *no* functions with
`mini-' in their names.

It would have been sufficient, if the name length were so important, to use
`minibuffer-resize' or `minibuf-auto-resize'. Similarly,
`minibuffer-max-height'. And `minibuffer' should probably come first in the
name: `minibuffer-resize', not `resize-minibuffer'.
We should change the names of the `mini-' window options and use temporary
aliases to ease deprecation of those names.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]