[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Rename `mini-' options

From: Miles Bader
Subject: Re: Rename `mini-' options
Date: Sat, 16 May 2009 16:13:03 +0900

"Stephen J. Turnbull" <address@hidden> writes:
> the name of the window in question is "minibuffer window".

Er, except that it's not.

For better or worse, Emacs traditionally distinguishes "the minibuffer"
from "the echo area", and resize-mini-windows applies to both.  So a
name which captures this subtlety is arguably better than one which lies
a bit for the sake of convenient document searching.

> Drew is right.  It is inconsistent with existing practice, and
> confuses something that is already rife with possibilities for
> confusion.

The variable in question _is_ existing practice -- it was introduced
almost a decade ago, in Emacs 21.

> There is precedent in the 3d-party resize-minibuffer mode, where the
> following names already exist:

That (long obsolete) mode does something _different_ than
resize-mini-windows:  it only applies to the minibuffer.  Thus even if
referring to "minibuffer-window" makes sense for that mode, that doesn't
mean it makes sense for Emacs' builtin behavior.

[I suppose you could argue against the "echo area"/"minibuffer" split,
and say we should just refer to them both as "the minibuffer"
(or whatever), but that's a different argument (and certainly not
something that should happen right now, as it's a big change).]


Education, n. That which discloses to the wise and disguises from the foolish
their lack of understanding.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]