[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs Package Management

From: Lennart Borgman
Subject: Re: Emacs Package Management
Date: Thu, 17 Sep 2009 12:43:59 +0200

On Thu, Sep 17, 2009 at 11:31 AM, Tassilo Horn <address@hidden> wrote:
>> The way most distros seems to solve this is to simply have different
>> repos for different distro versions. That should work for package.el
>> also. We could even adopt the stable/testing/bleeding scheme, so 3
>> repos for every supported major emacs version.
> I don't think that's a good approach, because it requires a lot of
> maintenance and testing on the package repository side.  It would be
> better if a package could specify something like
>  (package "my-package"
>    (version "1.0")
>    (need ">=emacs-23"))
>  (package "my-package"
>    (version "0.8")
>    (need ">=emacs-22.1" "<emacs-23"))
> and package.el does the resolving.

I agree, but I also think it should match against development sources
checkout date.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]