[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems with EDE

From: Eric M. Ludlam
Subject: Re: Problems with EDE
Date: Fri, 09 Oct 2009 20:24:25 -0400

Hi Sascha,

I appreciate the investigations you've been doing.  So you know, the
only things I can guarantee to work are the tests running in the CEDET
repository.  They are in cedet/tests/.  This test suite creates code off
in /tmp and runs against Make and Automake targets.

Ideally, when I fix things, I try to add tests for them.  I only caught
the testing bug for CEDET long after I wrote most of EDE, so there is
much left to do here.

I'm interested in working with you to get these types of issues fixed,
but I know I won't have much time till after the Punkin Chunk which is
Nov 6/7/8 of this year.


On Fri, 2009-10-09 at 14:42 +0200, Sascha Wilde wrote:
> Sascha Wilde <address@hidden> wrote:
> > With target type "sharedobject" ede projects build shared libraries.
> > Using an ede automake project building such an target fails in tow
> > respects:
> Building sharedobjects in ede make projects fails, too:
>     -*- mode: compilation; default-directory: "/tmp/cedet-test5/" -*-
>     Compilation started at Fri Oct  9 14:39:45
>     make -f Makefile libfoo.so
>     gcc    -march=athlon-xp -O3 -c greet.c
>     gcc -march=athlon-xp -O3  -L. -o libfoo.so greet.o
>     /usr/lib/crt1.o: In function `_start':
>     (.text+0x18): undefined reference to `main'
>     collect2: ld returned 1 exit status
>     make: *** [libfoo.so] Error 1
>     Compilation exited abnormally with code 2 at Fri Oct  9 14:39:45
> sascha

reply via email to

[Prev in Thread] Current Thread [Next in Thread]