[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot open termcap database

From: Dan Nicolaescu
Subject: Re: Cannot open termcap database
Date: Thu, 3 Dec 2009 20:53:58 -0800 (PST)

Stefan Monnier <address@hidden> writes:

  > >> > I tried to compile emacs for console, and I got the error
  > >> > Cannot open termcap database
  > >> > I solved the problem by installing ncurses-dev.
  > >> > One can introduce a check in ./configure.ac for the existence of 
terminfo data
  > >> > base when compiling for console and giving a suggestive error message?
  > >> I get bitten by this each time I compile and install Emacs on a new
  > >> Ubuntu GNU/Linux machine. Each time I have to surf around to
  > >> understand what to do about it. If it is possible for "us" to fix it
  > >> it would be nice.
  > > configure could try to detect either the termcap or terminfo headers and
  > > if none are present should error out.  All the systems we support
  > > nowadays that use ttys have either termcap or terminfo, so we don't lose
  > > anything.
  > I think the problem isn't so much the C headers, as the database.
  > For some reason, some distribution seem to have a tendency to install
  > some packages that provide the termcap header files without having the
  > termcap database installed, so compilation works fine, but it fails at
  > run-time.

The problem is different.  
If both termcap and terminfo headers are missing emacs uses
src/termcap.c files.  
But at run time it tries to look for /etc/termcap which modern
distributions do not install (they install the terminfo database).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]