[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems editing remote files - Solved [tramp/Cygwin]

From: Angelo Graziosi
Subject: Re: Problems editing remote files - Solved [tramp/Cygwin]
Date: Sun, 03 Oct 2010 00:19:34 +0200
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv: Gecko/20100915 Thunderbird/3.1.4

It seems I have solved installing a missing package.

Sorry for the noise.


Il 02/10/2010 23.40, Angelo Graziosi ha scritto:
For the sake of completeness I want to flag the following issue I meat
on Cygwin.

Trying to edit e remote file:

emacs -Q &
C-x C-f /ftp:address@hidden:foo.txt
Password for address@hidden:...

it works just fine on GNU/Linux Kubuntu 10.04, but HANGS/FREEZES on
Cygwin :(, though it uses 0% CPU (the cursor becomes a clock). I can
recover Emacs with C-g [*].

While it is hanging, I noticed that, on Cygwin, it uses (try?) the
Windows FTP program NOT the one which comes with Cygwin! Indeed 'ps'
shows the '.../system32/ftp' process.

Is this to be expected? Surely '.../system32/ftp' does not understand
POSIX paths...

Emacs is 24.050 r101732.


[*] Notice that 'ftp.remotehost' does not accept ssh connection, so
'ftp' method is the last resource, I think.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]