[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: address@hidden: Re: [Savannah-hackers-public] bzr move from sftp://

From: Alan Mackenzie
Subject: Re: address@hidden: Re: [Savannah-hackers-public] bzr move from sftp:// to bzr+ssh:// [done]]
Date: Mon, 18 Oct 2010 21:07:28 +0000
User-agent: Mutt/1.5.9i

Hi, Silvain

On Sun, Oct 10, 2010 at 09:03:01AM -0400, Richard Stallman wrote:
> ------- Start of forwarded message -------
> X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,RCVD_IN_DNSWL_NONE
>       autolearn=unavailable version=3.3.1
> Date: Sun, 10 Oct 2010 13:57:17 +0200
> From: Sylvain Beucler <address@hidden>
> To: address@hidden
> Subject: Re: [Savannah-hackers-public] bzr move from sftp:// to bzr+ssh://
>  [done]
> Message-ID: <address@hidden>
> Content-Type: text/plain; charset=us-ascii
> Content-Disposition: inline
> In-Reply-To: <address@hidden>

> Hi,

> The migration should be completed now.

> bzr:// and bzr+ssh:// are enabled.
> sftp:// is disabled.

> Your project bzr page is updated with the new URLs, e.g.:
> https://savannah.gnu.org/bzr/?group=emacs
> https://savannah.gnu.org/bzr/?group=pdf

> (note that "/srv/bzr" disappeared)

> bzr complained when I tried 'bzr switch', but apparently you can just
> edit your .bzr/branch/branch.conf manually in your working copies.

> Let us know if everything is alright.

I cannot access bzr+ssh.  I "just" edited my config file as you suggested
but it simply doesn't work.

When I try $ bzr update, I get the following abortion of an error

    You tried to execute: bzr serve --inet --directory=/ --allow-writes
    Sorry, you are not allowed to execute that command.
    bzr: ERROR: Connection closed: Unexpected end of message. Please check
    connectivity and permissions, and report a bug if problems persist.

which is of little help.  Here is my (branch) config file, contained in
the directory ~/emacs/emacs.bzr/trunk/.bzr/branch/branch.conf

    parent_location = bzr+ssh://address@hidden/emacs/trunk/
    public_branch = bzr+ssh://address@hidden/emacs/trunk/
    bound_location = bzr+ssh://address@hidden/emacs/trunk/
    bound = True
    submit_branch = file:///home/acm/emacs/emacs.bzr/quickfixes/

Nobody on address@hidden has been able to help me.  Help would be
very much appreciated (even if it's only a more appropriate address to
write to ;-).

Thanks in advance!

> - - Sylvain

Alan Mackenzie (Nuremberg, Germany).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]