[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

A problem building docs

From: Angelo Graziosi
Subject: A problem building docs
Date: Mon, 15 Nov 2010 23:17:38 +0100
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv: Gecko/20101027 Thunderbird/3.1.6

I have just upgraded from GNU/Linux Kubuntu 10.04 to Kubuntu 10.10 and noticed this issue building Emacs PDF manual.

Usually I bootstrap Emacs in a separate directory, 'Work', under Emacs tree. So

$ cd /tmp/emacs/Work/doc/emacs
$ make emacs.pdf
TEXINPUTS="/tmp/emacs/doc/emacs:/tmp/emacs/doc/emacs/../misc:" MAKEINFO="makeinfo --force -I /tmp/emacs/doc/emacs -I/tmp/emacs/doc/emacs" texi2pdf /tmp/emacs/doc/emacs/emacs.texi
egrep: Fine dell'intervallo non valida
/usr/bin/texi2dvi: cannot read .//tmp/emacs/doc/emacs/emacs.texi, skipping.
make: *** [emacs.pdf] Errore 1

(where : "egrep: Fine dell'intervallo non valida" == "egrep: End of intervall not valid")

Notice that in my environment:

$ echo $LANG

But If I run:

$ LANG="" make emacs.pdf

it works just fine, without the 'egrep' message, and 'emacs.pdf' is built. It is built also if I run directly:

$ texi2pdf emacs.texi

(this time *with* the egrep message).

These issues where absent in K10.04 with the same LANG...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]