[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cannot build on w32

From: Eli Zaretskii
Subject: Re: cannot build on w32
Date: Wed, 19 Jan 2011 11:03:18 -0500

> Date: Wed, 19 Jan 2011 10:53:28 -0500
> From: Sam Steingold <address@hidden>
> Cc: address@hidden
> On Wed, Jan 19, 2011 at 10:33 AM, Sam Steingold <address@hidden> wrote:
> > however, I now get a more insurmountable problem:
> >
> > "make bootstrap" dies with:
> >
> > gcc -I. -c  -mno-cygwin -mtune=pentium4 -O2
> > -IC:/gnu/gnuwin32/include -Demacs=1 -DHAVE_CONFIG_H -I../nt/inc
> > oo-spd/i386/print.o print.c
> > print.c:53:21: ftoastr.h: No such file or directory
> > make[2]: *** [oo-spd/i386/print.o] Error 1
> >
> > even though the above gcc command succeeds in src and lib/ftoastr.h is 
> > present.
> I worked around this by adding -I../lib to CFLAGS in src/makefile
> which is, obviously, not trt.

The w32 build is currently broken, since addition of files from gnulib
and the change of directory structure that involved were not accounted
for in the Windows makefiles.  If you can fix that the right way,
please do; if not, someone else will in a few days.

> BTW, retrying "make bootstrap" is very frustrating (it's a quadratic process!)

You shouldn't need to say "make bootstrap" after the the first such
command fails.  Just "make" should do.  (But I only tried that on
GNU/Linux, so perhaps there's some bug in the Windows build procedure
that breaks this.)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]