[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Still unable to build trunk

From: Eli Zaretskii
Subject: Re: Still unable to build trunk
Date: Mon, 24 Jan 2011 20:14:27 +0200

> Date: Sun, 23 Jan 2011 13:23:39 -0800
> From: Paul Eggert <address@hidden>
> CC: Jim Meyering <address@hidden>, address@hidden, 
>  address@hidden, address@hidden, bug-gnulib <address@hidden>
> I dunno, I just started doing some Emacs development after
> about five years' absence, and it was a pretty steep learning
> curve for me.  For example, nowhere is it stated that one
> really should use the obsolescent Python version 2.6.6,
> and that the current Python versions 2.7.1 and 3.1.3
> do not work well with the current bzr version.

No one complained about this in the past, I think, otherwise it would
have been in INSTALL.BZR.  However, the issue seems to be more related
to bzr installation on GNU/Linux or maybe to the various maintainers
of the bzr packages on GNU/Linux, than to Emacs: the Bazaar download
page (http://wiki.bazaar.canonical.com/DistroDownloads) doesn't tell
the requirements wrt Python and the Installation FAQ
(http://wiki.bazaar.canonical.com/InstallationFaq) says only this:
"Python >= 2.4".  Perhaps it would make sense to report this on the
Bazaar mailing list (address@hidden).

Any other issues that make the curve steep?

> Anyway, the point is moot, no?  Right now the Emacs VCS
> builds out of the box with the same tools as before.
> Maintainers don't need to have automake installed
> unless they also want to do gnulib-related development,
> for which automake is required anyway.

Maybe I misunderstood, but I thought something like "autoreconf -I m4"
was needed to build successfully after synchronizing with the
repository, if my last synchronization was before the import from
gnulib.  If that's not true, are you saying that just "./configure"
should be enough?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]