[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "no process" gnus bug when moving messages from nnml to imap folder

From: Giorgos Keramidas
Subject: Re: "no process" gnus bug when moving messages from nnml to imap folder
Date: Fri, 04 Feb 2011 10:23:40 -0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (gnu/linux)

On Fri, 04 Feb 2011 00:58:35 -0800, Lars Ingebrigtsen <address@hidden> wrote:
> Giorgos Keramidas <address@hidden> writes:
>> Another is that once this happens *once* for some message, then it's no
>> longer possible to `B m' even other normal messages.  It seems that when
>> Gmail drops the connection Gnus gets 'stuck' trying to recover from the
>> dropped connection, or trying to use the connection that is no longer
>> available.
> Do you get the same result if you use `B c' instead of `B m'?  I've
> been testing with `B c' (since copying is easier -- you can copy as
> many times as you want), and I am unable to reproduce this.  If I `B
> c' a NUL-bearing message, Gmail drops the connection, and if I then `B
> c' a non-NUL message, everything works just fine -- it reestablishes
> the connection and copies the message.

Yes, I get the same result with `B c'.  What seems odd is that I see two
different imap backends in my buffer list.  My ~/.gnus file includes:

  (setq gnus-nntp-server "news.sunsite.dk")
  (setq nntp-authinfo-function 'nntp-send-authinfo)
  (setq gnus-select-method '(nntp "news.sunsite.dk"))
  (setq gnus-secondary-select-methods '((nnml "")
                                        (nnimap "gmail"
                                                (nnimap-server-port 993)
                                                (nnimap-stream tls))))

Completion offers both `nnimap:gmail' and `nnimap:imap.gmail.com' as a
valid `B c' destination, but they both respond that the newly created
imap buffer has no connection when I move or copy messages from an nnml
source folder.

Other imap operations seem to work fine though, e.g. all the following
work fine:

  - copying messages from imap folders to local nnml folders
  - moving messages from imap folders to local nnml folders
  - getting new messages into imap folders by typing `g'
  - flag updates when I modify messages through gmail's web interface
    and type `g' in gnus

I can even see messages marked in Gnus with '!' as starred messages in
the web interface of Gmail, and when I unmark them in Gnus and type `g'
they get unstarred in the web UI too.

Whatever the problem is with `B c' and `B m' it seems specific to using
an imap folder as the destination of the messages.  As a source nnimap
folders seem to work more than fine.  I noticed that nnimap access is
now blazingly fast too.  I started using Gmail's imap access method only
because it's now very very fast to access the messages from Gnus too :-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]