[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: open-network-stream problems on W32

From: Christoph Scholtes
Subject: Re: open-network-stream problems on W32
Date: Tue, 26 Apr 2011 22:34:51 -0600
User-agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20110303 Thunderbird/3.1.9

On 4/26/2011 10:13 PM, Ted Zlatanov wrote:

It should work, it's what I'm using.  Are you loading gnutls.el before

No, I wasnt. Duh. Gnus works fine now with `ssl'. Thanks.

See `open-network-stream' for the code that Gnus is calling.  I changed
the subject and I hope that will get Lars and Chong's attention.
This means that you established the connection but the SSL certificate
could not be verified (by default, not fatal because the `verify-error'
and `verify-hostname-error' parameters to `gnutls-negotiate' are nil by

Chances are that the default certificate bundle,
/etc/ssl/certs/ca-certificates.crt, is not available on your system.  We
may have to attach this bundle to Emacs itself on W32 if there is
nothing suitable on the system (I would not depend on a Firefox or
Chrome or cygwin installation).

This does not seem to be a problem with Gnus (now that the other issue is resolved).

Receiving mail with Gnus works. However, sending mail does still not work.

I get an SMTP protocol error (from *Messages* w/gnutls-log-level=1):

Sending via mail...
No STARTTLS program was available (tried 'gnutls-cli')
220 mx.google.com ESMTP h74sm253108yhm.11
250-mx.google.com at your service, [...]
250-SIZE 35882577
530 5.7.0 Must issue a STARTTLS command first. h74sm253108yhm.11
221 2.0.0 closing connection h74sm253108yhm.11
smtpmail-send-it: Sending failed; SMTP protocol error

Do you think this is related to GnuTLS?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]