[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bzr not working?

From: Tim Cross
Subject: Re: bzr not working?
Date: Thu, 20 Oct 2011 08:33:41 +1100

On Thu, Oct 13, 2011 at 10:13 AM, Tim Cross <address@hidden> wrote:
> On Wed, Oct 12, 2011 at 7:43 PM, Eli Zaretskii <address@hidden> wrote:
>>> Date: Wed, 12 Oct 2011 10:35:13 +1100
>>> From: Tim Cross <address@hidden>
>>> Cc: address@hidden
>>> Has anyone heard anything more regarding a resolution for this issue?
>>> I've heard nothing from the savannah admins and stil cannot access the
>>> bzr repository.
>> You didn't subscribe to savannah-hackers-public, and evidently don't
>> read the archives, so you are unaware of the continuing discussion on
>> this matter.  Please look in the archives, if you are interested.
>> In a nutshell, after a day and a half of testing on 3 different
>> machine, my conclusion is that the problem I succeeded to reproduce is
>> a different problem.  It evidently causes any bzr connection that
>> takes longer than 1 hour to be forcibly dropped after precisely 1
>> hour.  (Due to the long time, I can only reproduce this with an
>> initial "bzr branch" command, and only on machines with slow
>> connection.)  There's probably some timeout somewhere on savannah, and
>> savannah admins will be looking for it.
>> But that is not your problem, because you reported a much faster
>> disconnect.  So I suggest that you run "bzr -Dhpss pull" on the
>> machine where this happens, and post the last portion of the .bzr.log
>> file as a followup to your original message.  That should give the
>> savannah admins information about what happens in the transport that
>> causes the problem.
>> TIA
> I have sent another message to the savannah list with the output from
> -Dhpss. I also tried accessing another bzr repository on savannah
> (color-theme) and got the same error. However, I can access bzr
> repositories on other hosts, such as launchpad.net with no problems,
> so it does seem to be savannah specific. I can also use the git
> mirrors on savannah with no problems, which is what I'm doing now to
> update my emacs code.
> While I would prefer to use bzr as it is the 'official' repository,
> using git is actually more convenient, seems faster and has better
> emacs integration. Now that the git mirror is being updated regularly,
> I'm happy to use it for the time being, so this issue is less urgent
> for me than it was.
> Tim

This issue has now been resolved. A quick update for the record and in
case anyone else encounters a similar issue.

The root cause of the problem was the deep packet inspection used by
the firewall used by my employer. The firewall was configured to drop
connections which were using 'unknown' protocols. At some point,
either the bzr protocols changed or the vendor changed the signatures
used to identify protocols (it looks like bzr may have changed, but
not certain about this). When this change occurred, the bzr protocol
was no longer recognized and the firewall dropped the connection.

The confusing/misleading aspect of this is that the nature of some
firewalls which use deep packet inspection is that they initially
allow some traffic through in order to perform the analysis and then
drop the connection if unrecognized. This gives the impression you
have gotten 'out' of your network and are connected tot he remote
server and that it is the remote server which drops the connection.

I have assisted our network admins in gathering sample bzr protocl
data, which they will submit to the firewall vendor so that they can
update their signatures for identifying bzr protocls. This should then
allow explicit configuration of what to do with bzr connections i.e.
allow/block depending on policy etc.

There is also an unrelated issue of savannah's bzr dropping
connections after 1 hour. This was done by savannah sys admins to deal
with runaway bzr processes - they configured a 'hard' 60min timeout
for bzr connections. I believe this has been increased to 120min and
is being reviewed. Apparently, newer versions of bzr have both
built-in connection timeouts and improved detection for idle
connections. Therefore, it is likely this hard coded limit will be
removed once savannah has updated bzr to a sufficiently recent
version.  I have no details of time lines or even firm confirmation
if/when these updates/changes will be performed and only mention it so
that anyone on a slow connection is aware that
bzr://bzr.savannah.gnu.org will timeout after 120min. I believe this
only affects users of the native bzr protocol and not those accessing
bzr repositories over http. Contact savannah if you have

Tim Cross

reply via email to

[Prev in Thread] Current Thread [Next in Thread]