[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 2/4] Refactor window-system configuration

From: Daniel Colascione
Subject: Re: [PATCH 2/4] Refactor window-system configuration
Date: Thu, 29 Dec 2011 14:29:24 -0800
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20111105 Thunderbird/8.0

On 12/29/11 2:21 PM, Dan Nicolaescu wrote:
> We don't use something like "#include TERM_HEADER" in any other place,
> it you really want to consolidate this stuff, creating a new header
> file to include seems better.

There's a first time for everything, and besides: other projects have
successfully used this approach. My initial revisions actually did
exactly what you suggest, but I realized that the solution was more
complex and didn't actually have any benefit.

Besides, we have src/s/*.h and src/m/*.h. At least this approach is

> Also "TERM" does not look like a good prefix
> in this case, it's meaning might be confused with the TERM environment
> variable (nsterm/w32term/xterm are not that great either, but better not
> propagate the confusion).

"Term", I think, it pretty clear in the context of Emacs. Using a
different name for the header constant wouldn't change the names of all
the datatypes in that header. It's better to at least be consistently

There's XTERM_HEADER, but this name has other issues.

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]