[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] browse-url-mailto

From: Chong Yidong
Subject: Re: [PATCH] browse-url-mailto
Date: Sat, 28 Jan 2012 10:48:09 +0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.92 (gnu/linux)

Lars Ingebrigtsen <address@hidden> writes:

>> (*) The naming is quite confusing: The variable
>> browse-url-mailto-function generalises the function
>> browse-url-mail. Maybe one of the two should be renamed.
> Yeah, that's a less than optimal naming.  Emacs-devel people -- would it
> make sense to change `browse-url-mailto-function' to
> `browse-url-mail-function'?  The variable was introduced (by, ahem, me)
> about a year ago, so it's within the pretest period...

The variable browse-url-mailto-function is used to respond to mailto:
urls.  Its value happens to be browse-url-mail, but I don't think it is
quite correct to say that this variable "generalises" browse-url-mail.

I think the present naming is fine.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]