[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "resource temporarily unavailable" errors on windows 7

From: Eli Zaretskii
Subject: Re: "resource temporarily unavailable" errors on windows 7
Date: Wed, 14 Mar 2012 19:47:00 +0200

> Date: Wed, 14 Mar 2012 12:27:31 +0800
> From: Alex Harsanyi <address@hidden>
> Cc: address@hidden
> > Question: does the problem happen right when you invoke the first
> > subprocess, or only after several subprocesses are already running,
> > and you try to invoke another one?
> It does not happen all the time, I'd say about 1 out of 4 tries for a
> `M-x diff-backup RET' call.  In terms of running processes,
> (process-list) returns:
>     (#<process ielm> #<process cleartool> #<process edit-server>
> #<process server>)
> BTW, it also happens when I run "emacs -Q", but less often, although
> when I tested the CreateThread failure, I run emacs -Q under gdb and
> it failed on the third try.

"On the third try" meaning that you have 2 other subprocesses running,
or did you invoke a process, then terminated it, then invoked another,
etc. 3 times?

> I also noticed that spontaneously, the Stack reserved size grows by
> about 10-12Mb (Free section decreases accordingly), than the memory is
> released a few seconds later.

Is that for the Emacs process?  If so, I would suspect that GC kicked
in.  You can see if that's so by setting garbage-collection-messages

Did you try increasing the size of the original request in
allocate_heap, and if you did, what was the maximum value that still
gives you a good Emacs session?

Thanks for working on this.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]