[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems with flet on last emacs

From: Thierry Volpiatto
Subject: Re: problems with flet on last emacs
Date: Fri, 29 Jun 2012 08:17:58 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.1.50 (gnu/linux)

Ivan Kanis <address@hidden> writes:

> Thierry Volpiatto <address@hidden> wrote:
>> Ivan Kanis <address@hidden> writes:
>>> Stefan Monnier <address@hidden> wrote:
>>>>>> stranges things happen with recent Emacs.
>>>>>> All functions that use flet don't work anymore.
>>>> And I hopefully have fixed this about half an hour ago.
>>> I tried looking at it but it goes through multiple macro expansion and
>>> quite frankly it's getting over my head.
>> Try to recompile contrib directory and slime.el.
> I did. I just tried again just to make sure. Here is the error plus the
> warnings:
> In toplevel form:
> slime-repl.el:18:23:Warning: `:authors' called as a function
> slime-repl.el:27:4:Warning: `:license' called as a function
> slime-repl.el:28:4:Warning: `:on-load' called as a function
> slime-repl.el:31:10:Warning: `:on-unload' called as a function
> slime-repl.el:32:16:Warning: `:swank-dependencies' called as a function
> slime-repl.el:129:1:Error: (slime-connection-output-buffer) is not a valid 
> place expression
> make: *** [/home/ivan/.emacs.d-bzr/slime/slime-repl.elc] Error 1

So maybe try removing all ".elc" and restart emacs.
It is working here not compiled on both version 24.1 and trunk version.

Get my Gnupg key:
gpg --keyserver pgp.mit.edu --recv-keys 59F29997 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]