[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Improvement suggestion for autoreconf.sh/INSTALL.BZR

From: Óscar Fuentes
Subject: Improvement suggestion for autoreconf.sh/INSTALL.BZR
Date: Tue, 10 Jul 2012 19:47:01 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.94 (gnu/linux)

After four months or so, updated my git checkout of Emacs, created a new
build directory and executed

myemacsbuild $ ../emacs/autoreconf

[some output elided]

Checking for autoconf (need at least version )...
unable to check
Checking for automake (need at least version 1.11)...

Building Emacs from Bzr requires the following specialized programs:
autoconf (minimum version )
automake (minimum version 1.11)

[some output elided]

Ok, autoconf is not installed, so install it, rerun the script but the
check for autoconf still fails. Then tried the suggested workaround on
autoconf's output:

myemacsbuild $ autoreconf -i -I m4 ../emacs/
Can't exec "libtoolize": No such file or directory at /usr/bin/autoreconf line 
Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 

So libtool is required, but no mention to that fact on
INSTALL.BZR. Installed it and tried again:

myemacsbuild $ autoreconf -i -I m4 ../emacs/
myemacsbuild $ _

Good, the configure script was created in the source directory.

So something is fishy with the detection of autoconf and it would be
good to report the absence/requirement of libtool from the script and/or

I'm using Kubuntu 12.04 64 bits.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]