[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using msysgit and Github and eshell/shell on Windows

From: Samuel Bronson
Subject: Re: Using msysgit and Github and eshell/shell on Windows
Date: Fri, 13 Jul 2012 11:36:09 -0400

On Jun 13, 2012, at 6:01 AM, Dmitry Gutov wrote:

Hi Bastian,

Whenever I run any git command that requires authentication (push,
pull, fetch basically), Emacs starts the git process, but it never
finishes. If I use the same commands (with the same executables) in
different shells such as CMD, powershell, the git shell or the msys
shell, git prompts me for my username and password. If I run the same
commands in Emacs on OSX, Emacs even prompts me for my possword in the
minibuffer! On Windows however, Emacs does not prompt me for my
username or password, but apparently still waits for it eternally and
the command just never completes.

It's a known issue under MS Windows. See 7.2 here:


Section 7.2 ends rather suddenly... but this happens because Windows doesn't use ptys, instead electing to have all "terminal" windows (called Consoles) handled by a single program, to which ntdll.dll is essentially hard-wired. (I suppose 9x probably implemented it in kernel32.dll directly?)

Any pointers on how to debug this would be greatly appreciated.

As far as I know, the generally accepted way is to set up Git to use
plink.exe instead of plain SSH. You'd need to launch pageant.exe before
using any Git functionality that requires authentication, but on the
upside, you'll only have to enter the password once per startup.

That's certainly what I do. Though I am, in point of fact, too lazy to even bother with passphrases on my SSH keys under *nix, and only did it on Windows because the prevalence of malware and the fact that I was keeping these particular keys on a flash drive made me uncomfortable leaving them unlocked.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]