[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs on OS X development

From: Paul Eggert
Subject: Re: Emacs on OS X development
Date: Mon, 23 Jul 2012 13:20:05 -0700
User-agent: Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20120714 Thunderbird/14.0

On 07/23/2012 12:45 PM, John Wiegley wrote:
> I build as follows:
>   configure --with-ns --enable-checking --enable-check-lisp-object-type
>             --prefix=$INSTALL_DIR CC=clang CXX=clang++ LD=clang
>             CFLAGS='-g -O0 -fno-omit-frame-pointer'
>             LDFLAGS="$CFLAGS"

I tried to reproduce the problem by building with above recipe,
on Ubuntu 12.04.  The LDFLAGS="$CFLAGS" part can't be right, since
this doesn't clone the CFLAGS settings of the previous line.  I
tried using LDFLAGS='-g -O0 -fno-omit-frame-pointer' but that
didn't link (the first diagnostic was
"nsterm.m:297: undefined reference to `objc_lookup_class'").

Can you please give a revised recipe?

> I then change my font to:
>   "-*-Courier-normal-normal-normal-*-15-*-*-*-m-0-iso10646-1"

How did you change your font?  Giving details here will make it
easier for others to reproduce the problem.

I notice that you're enabling multiple debugging options;
this might cause Emacs to be slow for you even if it works
fine for others.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]