[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Emacs-diffs] /srv/bzr/emacs/trunk r109327: Generalize INTERNAL_FIEL

From: Miles Bader
Subject: Re: [Emacs-diffs] /srv/bzr/emacs/trunk r109327: Generalize INTERNAL_FIELD between buffers, keyboards and frames.
Date: Mon, 06 Aug 2012 05:29:19 +0900

Paul Eggert <address@hidden> writes:
> The main issue is readability.  I find it more
> readable when the notation "f (x)" in ordinary C code
> means that F is a function, instead of some other
> construct that cannot possibly be a function.

The convention that an UPPERCASE name means "macro with possibly
non-function-like semantics" is a very well established idiom in C


Cynic, n. A blackguard whose faulty vision sees things as they are, not as
they ought to be. Hence the custom among the Scythians of plucking out a
cynic's eyes to improve his vision.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]