[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Buffer-/frame-local variables [Was: Re: Make buffer- and frame-local

From: Paul Eggert
Subject: Re: Buffer-/frame-local variables [Was: Re: Make buffer- and frame-locals a misc object]
Date: Fri, 17 Aug 2012 10:11:58 -0700
User-agent: Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20120714 Thunderbird/14.0

On 08/17/2012 06:20 AM, Stefan Monnier wrote:

> Elisp and Emacs generally uses "<type>-<field>" for accessors and
> "set-<type>-<field>" for setters.

As Dmitry didn't know that, he recently added several C functions
that didn't follow that naming convention.  I just now changed
three of their names to use the convention, in trunk bzr 109663.
(e.g., sub_char_table_set_contents -> set_sub_char_table_contents).
I assume there's no objection if the other names are changed similarly.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]