[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Simple defadvice's stopped working (commit daa84a03, Thu Nov 8 23:10

From: Ivan Kanis
Subject: Re: Simple defadvice's stopped working (commit daa84a03, Thu Nov 8 23:10:16 2012 -0500)
Date: Mon, 12 Nov 2012 11:36:18 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.1 (gnu/linux)

address@hidden (Adam Sjøgren) wrote:

> I just installed a new emacs-snapshot package¹, and got an error on
> startup, from these four lines in my .emacs.d/init.el:

I am getting the exact same error, same backtrace. I use the same hook
in gnus as Adam. 

Attempting to fix the issue I bootstrapped emacs. That usually fix
things, but no luck this time. I then recompiled all my personal files
with the new emacs since defadvice is a macro but I still get the error.

I have tried to reproduce with emacs -Q. I then byte compile a mock file
and load. Unfortunately I can't reproduce the bug :(

At this stage I am completely puzzled. I would like to give a recipe to
reproduce but can't think of anything. Any ideas on how I could do that?
Ivan Kanis

What we obtain too cheap, we esteem too lightly. It is dearness only
that gives everything its value.
    -- Thomas Paine

I am listening to "The Temptations - Mother Nature".

reply via email to

[Prev in Thread] Current Thread [Next in Thread]