[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Alternate design [Was: Re: [RFC] some reworking of struct window]

From: Stefan Monnier
Subject: Re: Alternate design [Was: Re: [RFC] some reworking of struct window]
Date: Mon, 25 Mar 2013 15:02:45 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.50 (gnu/linux)

>> For me, `payload' is associated with transport (or communication), so
>> it sounds a bit odd here.  But I won't oppose it (whereas I do oppose
>> "object").
> OK, what about neutral `contained'?

That would be a boolean field (is it contained?).  The closest noun
would be "contents" I think.

>>> +  ((W)->combination && (W)->horizontal)
>> I think this should be (eassert (WINDOWP ((W)->payload)), (W)->horizontal)
> This will require a lot of explicit checking whether W->payload is a window,
> for example in Fwindow_top_child and Fwindow_left_child.

I disagree with "a lot of" and I think making those checks explicit is good.

> I believe that we should treat dead windows as 'typeless' (that is,
> all of WINDOW_LEAF_P and WINDOW_xxx_COMBINATION_P should return false
> for them)

I'm not sure it's a good idea.

> and add explicit eassert where leaf or dead window can cause
> serious problems.

But here I do agree.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]