[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Emacs Display Recangular blocks instead of fonts

From: Kumar, Amit
Subject: RE: Emacs Display Recangular blocks instead of fonts
Date: Mon, 27 May 2013 07:07:49 +0000

Hi Stephen and Stefan,

Thank for the detailed answer and suggestion. 
I installed it from the source(v24.2) and it works like a charm!

Although when I tried to install the latest version 24.3 it failed to make
Somehow I couldn't find where exactly is "tparm"defined. Nothing fancy simple 
configure, make fails for this but worked for v24.2
I looked if the function was defined in any of the object files but could not 
find a reference at all, hope it makes more sense to you guys.
Please let me know what you think.

Thanks for your prompt weekend help!

make[1]: Entering directory `/root/emacs-24.3/src'
gcc -std=gnu99 -nostdlib -Demacs  -I. -I/root/emacs-24.3/src -I../lib 
-I/root/emacs-24.3/src/../lib   -I/usr/include/gtk-2.0 
-I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo 
-I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include 
-I/usr/include/freetype2 -I/usr/include/libpng12   -I/usr/include/freetype2     
  -I/usr/include/libxml2     -I/usr/include/freetype2      -MMD -MF deps/.d -MP 
    -g3 -O2   -Wl,-znocombreloc  \
          -o temacs pre-crt0.o /usr/lib64/crt1.o /usr/lib64/crti.o dispnew.o 
frame.o scroll.o xdisp.o menu.o xmenu.o window.o charset.o coding.o category.o 
ccl.o character.o chartab.o bidi.o cm.o term.o terminal.o xfaces.o xterm.o 
xfns.o xselect.o xrdb.o xsmfns.o xsettings.o xgselect.o gtkutil.o   emacs.o 
keyboard.o macros.o keymap.o sysdep.o buffer.o filelock.o insdel.o marker.o 
minibuf.o fileio.o dired.o cmds.o casetab.o casefiddle.o indent.o search.o 
regex.o undo.o alloc.o data.o doc.o editfns.o callint.o eval.o floatfns.o fns.o 
font.o print.o lread.o syntax.o unexelf.o bytecode.o process.o gnutls.o 
callproc.o region-cache.o sound.o atimer.o doprnt.o intervals.o textprop.o 
composite.o xml.o profiler.o     xfont.o ftfont.o xftfont.o ftxfont.o  
fontset.o fringe.o image.o  terminfo.o lastfile.o    vm-limit.o   
../lib/libgnu.a      -ltiff -ljpeg -lpng -lz -lm -lgif -lXpm -L/lib64 
-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 
-lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   -lSM -lICE 
-lX11 -lXrender -lXft -lXrender -lfontconfig -lfreetype -lX11      -lrt -lrt    
-lxml2 -lz -lm      -ltermcap   -lselinux -lfreetype   -lfontconfig      
-lpthread   -lm -lgcc -lc -lgcc /usr/lib64/crtn.o
fns.o: In function `sxhash_float':
/root/emacs-24.3/src/fns.c:4139: warning: memset used with constant zero length 
parameter; this could be due to transposed parameters
/root/emacs-24.3/src/fns.c:4139: warning: memset used with constant zero length 
parameter; this could be due to transposed parameters
/root/emacs-24.3/src/fns.c:4139: warning: memset used with constant zero length 
parameter; this could be due to transposed parameters
terminfo.o: In function `tparam':
/root/emacs-24.3/src/terminfo.c:50: undefined reference to `tparm'
collect2: ld returned 1 exit status
make[1]: *** [temacs] Error 1
make[1]: Leaving directory `/root/emacs-24.3/src'
make: *** [src] Error 2 

-----Original Message-----
From: Stephen J. Turnbull [mailto:address@hidden 
Sent: Sunday, May 26, 2013 9:43 PM
To: Kumar, Amit
Cc: address@hidden
Subject: Emacs Display Recangular blocks instead of fonts

Kumar, Amit writes:

 > Cannot convert string "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*" to 
 > type FontStruct  > Warning: Cannot convert string 
 > "-*-helvetica-medium-r-*--*-120-*-*-*-*-iso8859-1" to type FontStruct

These are the old-style "server-side" font objects.  These warnings are from 
Xlib, and indicate that you have a badly configured installation of X11.  It's 
not really an Emacs problem; your distro is broken.

 > What I don't understand is why is emacs resorting to these fonts,  > if it 
 > has problems can't it use some other fonts to display a  > normal screen?

It should be doing so; I don't know why it doesn't.  I would guess that Emacs 
is not able to find any fonts at all.  You do seem to have the appropriate 
fonts installed in your file system (the ones in /usr/share/X11/fonts), so 
there's a problem with the X server.

I don't recall exactly how modern X servers handle server-side fonts.
You may need a separate "font server" running to use the bitmap and other 
old-style fonts you have installed.  Look for a font-server package (or change 
distros, see below).

 > Fonts directory listed in /etc/fonts/fonts.conf

This a configuration file for fontconfig, which is irrelevant to FontStruct.  
It's probable that your Emacs was built only with server-side fonts (21.4 is 
very old), but your server doesn't understand how to render them.  So it 
substitutes boxes.

The current series of Emacs is 24.x, and older Emacs versions are officially 
unsupported.  That doesn't mean you won't get help, but it does mean that there 
are no problems with Emacs 21 where the default solution is anything but 
"Upgrade, then come talk to us".

If upgrading is possible, you really should do so (for many reasons, not just 
to make it easier for us to support you).

(Aside: If Scientific Linux [sic] distributes such an old Emacs, what other 
problems may be hiding in the distro?  All of the main distros keep up with 
Emacs releases with a lag of only a couple weeks.
Many provide a "bleeding edge" beta package as well.  The evidence is strong 
that Emacs is both a valuable package and one that is easy to keep up to date.  
If Scientific Linux doesn't do so ....)

 > $ fc-list | grep -i "courier"
 > Courier:style=Regular
 > $ fc-list | grep -i helvetica
 > Helvetica:style=Regular

These are again fontconfig specs; since fontconfig finds these fonts, that's 
strong evidence that your Emacs is too old to render them.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]