[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fallback mode for image magick?

From: Klaus-Dieter Bauer
Subject: Re: Fallback mode for image magick?
Date: Wed, 3 Jul 2013 00:12:27 +0200

2013/7/2 Klaus-Dieter Bauer <address@hidden>
2013/6/28 Lars Magne Ingebrigtsen <address@hidden>
Klaus-Dieter Bauer <address@hidden> writes:

> My intent however is to write a fix, that makes this a default
> fallback for code that wants to use builtin support without the need
> to edit the third party source code. Finding out what functions and
> variables I need to emulate is the hard part here for me.

If you could implement native ImageMagick support for Emacs under
Microsoft Windows, that would probably be even better.  :-)

(domestic pets only, the antidote for overdose, milk.)
  bloggy blog http://lars.ingebrigtsen.no/

So, I got it to compile by adding DEF_IMGLIB_FN and LOAD_IMGLIB_FN entries like for the other types, following the hint from an older discussion [1] and correcting it. For reference I have attached the patches to nt/configure.bat and src/image.c.

Sadly however, I now can't get the MinGW bundle of ImageMagick working.

convert.exe: UnableToOpenModuleFile `C:\Users\klaus\.magick\IM_MOD_RL_PNG_.dll': No such file or directory @ warning/module.c/GetMagickModulePath/812.

While the function `imagemagick-types` is now defined in the session, still no resizing occurs, probably because ImageMagick silently fails.

Also in this configuration JPEG is not included in `(imagemagick-types)` for some reason. 

Apparently the official ImageMagick version for Windows is tightly bound to Visual Studio, which doesn't help the case either.

Honestly, the fallback-solution gets more and more attractive ;) 

I now got emacs to compile with static linking and image-magick support linking to the standard binary distribution of ImageMagick for Windows.

Basically that version of emacs works fine. `imagemagick-types` is defined, jpeg/png images can be displayed when the jpeg-62.dll etc are on PATH, emacs starts without complaint if they are not.

Imagescaling however still doesn't work.

I cross-checked with Cygwin, there scaling works in org-mode (not though when doing ``(insert-image (create-image .... :width 100))``). 

Is there something I am missing?

kind regards, Klaus

reply via email to

[Prev in Thread] Current Thread [Next in Thread]