[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: TRAMP: Host name must not match method ...

From: Michael Albinus
Subject: Re: TRAMP: Host name must not match method ...
Date: Fri, 16 Aug 2013 15:15:10 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.50 (gnu/linux)

Matt McClure <address@hidden> writes:

> Hi,

Hi Matt,

> In recent nightly builds of Emacs, I'm struggling to use TRAMP file
> paths as I've usually done. I'm getting an error message "Host name
> must not match method `ssh'".
> Here's a minimal test case:
>     $ open -a Emacs --args -Q --no-site-file
> Then:
>     C-x C-f /ssh:address@hidden:/ RET

I'm not able to reproduce it. Trying with other IP address and user name
of course, but it works locally (as every single day) for me.

> Here's what *Messages* says:
>     For information about GNU Emacs and the GNU system, type C-h C-a.
>     Tramp: Opening connection for address@hidden using ssh...
>     Tramp: Sending command `exec ssh -l vagrant  -o
> ControlPath=/var/folders/_d/5p0jtv397qs73qr_frd6bw180000gn/T/address@hidden:%p
> -o ControlMaster=auto -o ControlPersist=no -e none'
>     Tramp: Waiting for prompts from remote shell...done
>     Tramp: Found remote shell prompt on `'
>     Tramp: Opening connection for address@hidden using ssh...done
>     completion--some: Host name must not match method `ssh'

It is unclear where the error comes from. Could you, please, perform

(setq debug-on-error t tramp-verbose 6)

and rerun the test. There might be a backtrace, and there will be a
Tramp debug buffer. Both might show us what's up.

> I tried to reproduce more succinctly with:
>     $ open -a Emacs --args -Q --no-site-file --eval '(find-file
> "/ssh:address@hidden:/")'
> To my surprise, it worked as intended rather than failing. So maybe
> that's a clue.

No, this doesn't help. The test in Tramp is not performed when you are
not in interactive mode. So it is normal that it works for you this way.

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]