|Subject:||Re: Apologia for bzr|
|Date:||Tue, 7 Jan 2014 01:02:53 +0100|
That's a bad idea since a fundamental part of the "interactive" userLennart Borgman <address@hidden> writes:
> On Mon, Jan 6, 2014 at 9:32 PM, Daniel Colascione <address@hidden> wrote:
>> On 01/06/2014 12:27 PM, Richard Stallman wrote:
>>> Conceivably we could rename "window" to "pane" and "frame" to "window".
>>> I think the two renamings would have to be done in two different releases,
>>> perhaps a year or two apart.
>> I don't think we could pull off this renaming. At least on the lisp level,
>> we would have to maintain compatibility aliases effectively forever,
>> doubling the number of lisp symbols dealing with these concepts. One does
>> not simply rename a function that's been in constant use for 20 years.
>> Sure, you might argue, we could change the labels we assign these concepts
>> in the UI and leave lisp alone, but the lisp symbols are too closely tied
>> to the UI (with respect to keybindings and M-x) to change the two
>> The best thing we can do is explain in the tutorial and manual the
>> correspondence between Emacs and common terms.
> We are talking about the user level. Interactive function names can be
interface is completion, so if you are trying to find some
functionality, getting two names in the set of completions that look
like they might do different things because of using different terms,
this will not help the user figuring out what to do.
|[Prev in Thread]||Current Thread||[Next in Thread]|