[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Fri, 04 Apr 2014 11:14:31 +0300
> Date: Fri, 04 Apr 2014 01:04:37 -0700
> From: Paul Eggert <address@hidden>
> CC: address@hidden
> Eli Zaretskii wrote:
> > I suggested ALEN because we have AREF and ASIZE. Maybe AELTS or
> > ALENGTH would be better.
> The most common name for this macro in other projects is probably
> ARRAY_SIZE. That's what's in libiberty, for example. There are other
> names (ARRAY_CARDINALITY, SIZEOF) but ARRAY_SIZE seems to be more popular.
The SIZE part was what I originally objected: "size" in C is mostly
measured in bytes, which this one isn't. ARRAY_SIZE will be confusing
since we already have ASIZE.