[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Weird behaviour in current Emacs master

From: Lele Gaifax
Subject: Weird behaviour in current Emacs master
Date: Fri, 18 Apr 2014 20:55:29 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.4.50 (gnu/linux)

Hi all,

today I spent a few hours investigating a very strange behaviour I got
with current Emacs trunk, that I will try to explain.

Some context: at work I have an Ubuntu desktop, where I use the
https://launchpad.net/~ubuntu-elisp/+archive/ppa Emacs package, rebuilt
every day from the master repository. This morning I did update the
system because I planned to upgrade it in the evening to the just
released 14.04 version, so I got latest Emacs and used it.

In the afternoon, editing a very simple HTML snippet, the strange thing
happened. I was able to replicate it with the following very simple code
in the buffer, where "^" is the "point":


When I insert "<tr>", the last char (that is, ">"), triggers the strange
thing: in my case it immediately jumps to the eye because I have
hl-line-mode active, so the remaining part of the buffer is highlighted,
that is, from the end of the second line to the end of the third line,
including the "</table>" text: effectively, a C-a brings the cursor on
the first column of the second line, a C-e brings it to the end of the
third line!

I first tried to recompile Emacs by myself, with the very same
results. Then I discovered that it must be something in the minor modes
that my configuration activates, because "emacs -Q" does not exhibit the
problem. Gosh... :-(

Back at home, I was pleased to find that my installation there was
working without problems and thankfully I compiled it just a five days
ago, so I restarted the investigation. I pulled and recompiled latest
version and effectively the problem appeared. While writing this post I
then tried to bisect the problem and eventually identified it with the
following changeset:

    commit 00cbdba426ab08964ee8eae14a890945df33b595
    Author: Eli Zaretskii <address@hidden>
    Date:   Mon Apr 14 18:32:27 2014 +0300

        Fix bidirectional redisplay when deletion creates a paragraph start.

         src/insdel.c (invalidate_buffer_caches): When deleting or replacing
         text, invalidate the bidi_paragraph_cache upto and including the
         preceding newline.

The buffer is in html-mode major mode, and this is the list of activated
minor modes:

    Enabled minor modes: Auto-Composition Auto-Compression
    Auto-Encryption Auto-Fill Auto-Insert Column-Number Electric-Indent
    Electric-Pair File-Name-Shadow Flyspell Font-Lock
    Global-Auto-Complete Global-Font-Lock Hl-Line Jabber-Activity
    Line-Number Mouse-Wheel Shell-Dirtrack Show-Paren Subword
    Transient-Mark Whitespace Whitespace-Cleanup Winner Yas Yas-Global

Apparently, neither html-mode nor hl-line-mode are involved, because the
problem happens also in fundamental-mode with the latter minor disabled.

Is there anything I can do to help you understand what's going wrong? I
could try "bisecting" the activation of all those minor modes... but
maybe you have some better hint on how to proceed.

Thank you in advance for any advice,
ciao, lele.
nickname: Lele Gaifax | Quando vivrò di quello che ho pensato ieri
real: Emanuele Gaifas | comincerò ad aver paura di chi mi copia.
address@hidden  |                 -- Fortunato Depero, 1929.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]