[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Trunk r117046 fails on systems with older automake

From: Andy Moreton
Subject: Re: Trunk r117046 fails on systems with older automake
Date: Thu, 08 May 2014 09:00:22 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.90 (windows-nt)

On Thu 08 May 2014, Eli Zaretskii wrote:

>> From: Andy Moreton <address@hidden>
>> Date: Thu, 08 May 2014 01:05:22 +0100
>> In my previous setup I was keeping tools supplied form the mingw project
>> separated from all tools from other projects to prevent inadvertantly
>> overwriting DLLs with incompatible versions. The aim was to do some of
>> the (non-existant) package manager's work, and ensure that the toolchain
>> setup is repeatable.
>> I've now moved pkg-config and pkg.m4 under the msys tree, which seems to
>> make things happier. All of the rest of the libraries not sourced from
>> the mingw project still live in a separate tree, and the configury seems
>> happy with that.
> I don't understand how moving things could solve this, perhaps you had
> some files/programs duplicated.  FWIW, my MSYS and MinGW trees are
> separate.
> Anyway, is your problem solved now?


It seems that whatever I did the configury ignored the autotools from
ezwinports installed under c:/emacs/mingw-devel, and always used the
ones from c:/mingw/msys (regardles of PATH). If I uninstalled the msys
versions then autogen.sh simply failed. In addition, the generated
configure could find pkg-config, but not pkg.m4 unless it was moved into
the msys tree (I tried using ACLOCAL_PATH for this, to no avail).



reply via email to

[Prev in Thread] Current Thread [Next in Thread]