[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building Emacs for GNUstep

From: andres . ramirez
Subject: Re: Building Emacs for GNUstep
Date: Thu, 10 Jul 2014 17:12:35 -0500
User-agent: SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Gojō) APEL/10.8 Emacs/24.3 (x86_64-unknown-linux-gnu) MULE/6.0 (HANACHIRUSATO)

Hi Guys. Following this thread.

I tried to compile the ns-port on my distro (archlinux)

uname -a
Linux tiahua 3.15.3-1-ARCH #1 SMP PREEMPT Tue Jul 1 07:32:45 CEST 2014 x86_64 

after installing:
gnustep-gui-clang-svn (AppKit.h)

then I did :
 ./configure --with-ns --with-gnustep-conf=/etc/GNUstep/GNUstep.conf

Then I did:

With this output:
clang -Demacs  -I. -I. -I../lib -I./../lib    -D_REENTRANT -fPIC 
-fno-strict-aliasing -I/usr/System/Library/Headers -I/usr/Local/Library/Headers 
-I/usr/include/alsa  -pthread -I/usr/include/librsvg-2.0 
-I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/cairo 
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 
-I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz 
-I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/libdrm 
-I/usr/include/libpng16  -fopenmp -DMAGICKCORE_HDRI_ENABLE=1 
-DMAGICKCORE_QUANTUM_DEPTH=16 -I/usr/include/ImageMagick-6  
-I/usr/include/libxml2  -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include     
    -MMD -MF deps/.d -MP -I/usr/include/p11-kit-1   -Wno-switch 
-Wno-tautological-constant-out-of-range-compare -Wno-pointer-sign  -g3 -O2  
-Wl,-znocombreloc  -L/usr/System/Library/Libraries 
-L/usr/Local/Library/Libraries \
  -o temacs  vm-limit.o dispnew.o frame.o scroll.o xdisp.o menu.o  window.o 
charset.o coding.o category.o ccl.o character.o chartab.o bidi.o cm.o term.o 
terminal.o xfaces.o   dbusbind.o emacs.o keyboard.o macros.o keymap.o sysdep.o 
buffer.o filelock.o insdel.o marker.o minibuf.o fileio.o dired.o cmds.o 
casetab.o casefiddle.o indent.o search.o regex.o undo.o alloc.o data.o doc.o 
editfns.o callint.o eval.o floatfns.o fns.o font.o print.o lread.o syntax.o 
unexelf.o bytecode.o process.o gnutls.o callproc.o region-cache.o sound.o 
atimer.o doprnt.o intervals.o textprop.o composite.o xml.o  profiler.o 
decompress.o       fontset.o fringe.o image.o  nsterm.o nsfns.o nsmenu.o 
nsselect.o nsimage.o nsfont.o  terminfo.o lastfile.o      ../lib/libgnu.a    
-lgnustep-gui -lgnustep-base -lobjc -lpthread     -lasound  -lrsvg-2 -lm 
-lgio-2.0 -lgdk_pixbuf-2.0 -lgobject-2.0 -lglib-2.0 -lcairo  
-lMagickWand-6.Q16HDRI -lMagickCore-6.Q16HDRI  -lacl    -lrt  -ldbus-1     
-lxml2  -lgpm   -lncurses        -lgnutls  -lpthread   -lm -lz
nsterm.m:5015: error: undefined reference to 'macfont_get_nsctfont'
nsfns.m:1391: error: undefined reference to 'macfont_get_nsctfont'
clang: error: linker command failed with exit code 1 (use -v to see invocation)
Makefile:664: recipe for target 'temacs' failed
make[1]: *** [temacs] Error 1
make[1]: Leaving directory '/home/aramirez/abs/emacs/ns/emacs-24.3.92/src'
Makefile:382: recipe for target 'src' failed
make: *** [src] Error 2

Any idea how to solve this?.

At Wed, 09 Jul 2014 10:47:30 +0400,
Dmitry Antipov wrote:
> On 07/09/2014 06:25 AM, Stefan Monnier wrote:
> > I just tried to build Emacs for GNUstep under Debian (from trunk).
> > The configure and build worked smoothly, but when I try to run the
> > executable I get a seg-fault:
> >
> >     Program received signal SIGSEGV, Segmentation fault.
> >     0xf76e905f in objc_msg_lookup () from 
> > /usr/lib/i386-linux-gnu/libobjc.so.4
> >     (gdb) bt
> >     #0  0xf76e905f in objc_msg_lookup () from 
> > /usr/lib/i386-linux-gnu/libobjc.so.4
> >     #1  0x081e8028 in x_set_window_size (f=0x877a0d0, change_grav=142057680,
> >         width=14, height=70, pixelwise=120) at nsterm.m:1382
> >     #2  0x00000000 in ?? ()
> >
> >     Lisp Backtrace:
> >     "x-create-frame" (0xffffcb28)
> >     "x-create-frame-with-faces" (0xffffccb8)
> >     "make-frame" (0xffffce48)
> >     "frame-initialize" (0xffffcfd8)
> >     "command-line" (0xffffd1ac)
> >     "normal-top-level" (0xffffd310)
> >     (gdb)
> >
> > Any idea what might be going on?
> Hm... I was able to run, but with the very miserable results
> (see screenshot) - text rendering makes Emacs unusable.
> Fedora 20 x86_64, stock GNUstep packages:
> gnustep-gui-0.23.1-6.fc20.x86_64
> gnustep-back-0.23.0-5.fc20.x86_64
> gnustep-base-libs-1.24.4-8.fc20.x86_64
> gnustep-gui-libs-0.23.1-6.fc20.x86_64
> gnustep-base-devel-1.24.4-8.fc20.x86_64
> gnustep-filesystem-2.6.6-2.fc20.x86_64
> gnustep-base-1.24.4-8.fc20.x86_64
> gnustep-make-2.6.6-2.fc20.x86_64
> gnustep-gui-devel-0.23.1-6.fc20.x86_64
> Dmitry

reply via email to

[Prev in Thread] Current Thread [Next in Thread]