[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Requesting review before pushing patch to ELPA

From: Jackson Hamilton
Subject: Re: Requesting review before pushing patch to ELPA
Date: Thu, 5 Feb 2015 10:48:40 -0800

I figured out the issue: I had to use the git+ssh url, and I added my ssh key to my savannah account. Then git push worked.

On Thu, Feb 5, 2015 at 10:17 AM, Jackson Hamilton <address@hidden> wrote:
Heys guys, I am having an issue pushing to ELPA:

$ git push origin master
Counting objects: 1127, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (431/431), done.
fatal: read error: Connection reset by peer
error: pack-objects died of signal 13
error: failed to push some refs to 'git://git.sv.gnu.org/emacs/elpa'

I am not sure what's up.

I looked up these errors, and apparently "error: pack-objects died of signal 13" has something to do with the size of the push? The push does include my whole project history, but I don't have any particularly large binary files in my repo besides maybe 6 or 7 .png files.

I've added the "Project Members GPG Keyring" with gpg --import. Perhaps I am still not properly authenticated? (Sorry, I'm not too familiar with gpg or keys.)


On Thu, Feb 5, 2015 at 6:10 AM, Stefan Monnier <address@hidden> wrote:
> The attached patches are the current representation of what I intend to
> merge. (Same subtree strategy as before.)

Looks good to me,


PS: Regarding "eval: (when (fboundp 'rainbow-mode) (rainbow-mode 1))",
this is usually considered a misfeature: the file does not need or make
special use of rainbow-mode.  Instead, *you* just happen to like using
rainbow-mode when editing this file.  So this customization should be in
your ~/.emacs rather than in the file itself.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]