[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: VC mode and git

From: Eli Zaretskii
Subject: Re: VC mode and git
Date: Sun, 05 Apr 2015 20:56:34 +0300

> Date: Sun, 05 Apr 2015 13:42:44 -0400
> From: Richard Stallman <address@hidden>
> CC: address@hidden, address@hidden, address@hidden,
>       address@hidden
>   > The changes pushed include only changes to lisp/ChangeLog.  They don't
>   > include the code changes in rmail.el and in browse-url.el.
> 'git diff origin/master' showed the changes in all three files.
> Then I did git commit and git push.  Why didn't that install them?

It did; I was mistaken.  Sorry.

> I did git pull again, and it told me there was a problem
> lisp/ChangeLog again, but there was no conflict in it.
> Then I did git commit again.
> Then I did git push again, and got this.
>     To address@hidden:/srv/git/emacs.git
>      ! [rejected]        master -> master (non-fast-forward)
>     error: failed to push some refs to 'address@hidden:/srv/git/emacs.git'
>     To prevent you from losing history, non-fast-forward updates were rejected
>     Merge the remote changes (e.g. 'git pull') before pushing again.  See the
>     'Note about fast-forwards' section of 'git push --help' for details.
> I have no idea what that means.

It means you tried to push some commits that are not descendants of
the last commit on savannah.  The savannah repository is configured to
reject such pushes.

What does "git diff origin/master" show now?

And what does "git status -s" show?

>       > My guess would be that these are still stashed, and need to be
>       > unstashed and then pushed.
> How can I tell?

Forget it for now, it was probably my mistake.  Your changes in
rmail.el and browse-url.el are on savannah.  What's left is to find
out why you still get error messages when pushing.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]